What’s Vulnerable › Vulnerabilities
CVE-2016-10565
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-311
Description
operadriver is a Opera Driver for Selenium. operadriver versions below 0.2.3 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Affected products
- HackerOne operadriver node module: before 0.2.3 — fixed in 0.2.3
How to fix
Upgrade to a fixed version: HackerOne operadriver node module 0.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10565 or the next vulnerability affects your stack