What’s Vulnerable › Vulnerabilities
CVE-2016-10568
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-29 · updated 2026-06-17
- Weakness: CWE-311
Description
geoip-lite-country is a stripped down version of geoip-lite, supporting only country lookup. geoip-lite-country before 1.1.4 downloads data resources over HTTP, which leaves it vulnerable to MITM attacks.
Affected products
- HackerOne geoip-lite-country node module: before 1.1.4 — fixed in 1.1.4
How to fix
Upgrade to a fixed version: HackerOne geoip-lite-country node module 1.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10568 or the next vulnerability affects your stack