What’s Vulnerable › Vulnerabilities
CVE-2016-10570
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-29 · updated 2026-06-17
- Weakness: CWE-311
Description
pngcrush-installer is an installer for Pngcrush. pngcrush-installer versions below 1.8.10 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Affected products
- HackerOne pngcrush-installer node module: before 1.8.10 — fixed in 1.8.10
How to fix
Upgrade to a fixed version: HackerOne pngcrush-installer node module 1.8.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10570 or the next vulnerability affects your stack