What’s Vulnerable › Vulnerabilities
CVE-2016-10571
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-311
Description
bkjs-wand is imagemagick wand support for node.js and backendjs bkjs-wand versions lower than 0.3.2 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Affected products
- HackerOne bkjs-wand node module: before 0.3.2 — fixed in 0.3.2
How to fix
Upgrade to a fixed version: HackerOne bkjs-wand node module 0.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10571 or the next vulnerability affects your stack