What’s Vulnerable › Vulnerabilities
CVE-2016-10573
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-29 · updated 2026-06-17
- Weakness: CWE-311
Description
baryton-saxophone is a module to install and launch Selenium Server for Mac, Linux and Windows. baryton-saxophone versions below 3.0.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Affected products
- HackerOne baryton-saxophone node module: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: HackerOne baryton-saxophone node module 3.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10573 or the next vulnerability affects your stack