What’s Vulnerable › Vulnerabilities
CVE-2016-10576
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-01 · updated 2026-06-17
- Weakness: CWE-311
Description
Fuseki server wrapper and management API in fuseki before 1.0.1 downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested resources with an attacker controlled copy if the attacker is on the network or positioned in between the user and the remote server.
Affected products
- HackerOne fuseki node module: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: HackerOne fuseki node module 1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10576 or the next vulnerability affects your stack