What’s Vulnerable › Vulnerabilities
CVE-2016-10578
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-29 · updated 2026-06-17
- Weakness: CWE-311
Description
unicode loads unicode data downloaded from unicode.org into nodejs. Unicode before 9.0.0 downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks.
Affected products
- HackerOne unicode node module: before 9.0.0 — fixed in 9.0.0
How to fix
Upgrade to a fixed version: HackerOne unicode node module 9.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10578 or the next vulnerability affects your stack