What’s Vulnerable › Vulnerabilities
CVE-2016-10591
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-29 · updated 2026-06-17
- Weakness: CWE-311
Description
Prince is a Node API for executing XML/HTML to PDF renderer PrinceXML via prince(1) CLI. prince downloads zipped resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested tarball with an attacker controlled tarball if the attacker is on the network or positioned in between the user and the remote server.
Affected products
- HackerOne prince node module: from 1.4.4 before 1.4.6 — fixed in 1.4.6
How to fix
Upgrade to a fixed version: HackerOne prince node module 1.4.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10591 or the next vulnerability affects your stack