What’s Vulnerable › Vulnerabilities
CVE-2016-10610
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-01 · updated 2026-06-17
- Weakness: CWE-311
Description
unicode-json is a unicode lookup table. unicode-json before 2.0.0 downloads data resources over HTTP, which leaves it vulnerable to MITM attacks.
Affected products
- HackerOne unicode-json node module: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: HackerOne unicode-json node module 2.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10610 or the next vulnerability affects your stack