What’s Vulnerable › Vulnerabilities
CVE-2016-10625
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-01 · updated 2026-06-17
- Weakness: CWE-311
Description
headless-browser-lite is a minimal npm installer for phantomjs and slimerjs with no external dependencies. headless-browser-lite downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Affected products
- HackerOne headless-browser-lite node module: before 2015.4.18-a — fixed in 2015.4.18-a
How to fix
Upgrade to a fixed version: HackerOne headless-browser-lite node module 2015.4.18-a. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2016-10625 or the next vulnerability affects your stack