What’s Vulnerable › Vulnerabilities
CVE-2016-10703
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-12-14 · updated 2026-06-17
- Weakness: CWE-20
Description
A regular expression Denial of Service (DoS) vulnerability in the file lib/ecstatic.js of the ecstatic npm package, before version 2.0.0, allows a remote attacker to overload and crash a server by passing a maliciously crafted string.
Affected products
- HackerOne ecstatic node module: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: HackerOne ecstatic node module 2.0.0. Check the vendor advisory for mitigations.
References
- https://advisory.checkmarx.net/advisory/CX-2016-4450
- https://github.com/jfhbrook/node-ecstatic/commit/71ce93988ead4b561a8592168c72143907189f01
- https://www.checkmarx.com/advisories/denial-of-service-dos-vulnerability-in-ecstatic-npm-package/
- https://advisory.checkmarx.net/advisory/CX-2016-4450
- https://github.com/jfhbrook/node-ecstatic/commit/71ce93988ead4b561a8592168c72143907189f01
- https://www.checkmarx.com/advisories/denial-of-service-dos-vulnerability-in-ecstatic-npm-package/
Get alerted when CVE-2016-10703 or the next vulnerability affects your stack