What’s Vulnerable › Vulnerabilities
CVE-2016-10713
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-13 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in GNU patch before 2.7.6. Out-of-bounds access within pch_write_line() in pch.c can possibly lead to DoS via a crafted input file.
Affected products
- GNU patch: before 2.7.6 — fixed in 2.7.6
How to fix
Upgrade to a fixed version: GNU patch 2.7.6. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103063
- https://access.redhat.com/errata/RHSA-2019:2033
- https://git.savannah.gnu.org/cgit/patch.git/commit/src/pch.c?id=a0d7fe4589651c64bd16ddaaa634030bb0455866
- https://usn.ubuntu.com/3624-1/
- https://usn.ubuntu.com/3624-2/
- http://www.securityfocus.com/bid/103063
- https://access.redhat.com/errata/RHSA-2019:2033
- https://git.savannah.gnu.org/cgit/patch.git/commit/src/pch.c?id=a0d7fe4589651c64bd16ddaaa634030bb0455866
- https://usn.ubuntu.com/3624-1/
- https://usn.ubuntu.com/3624-2/
Get alerted when CVE-2016-10713 or the next vulnerability affects your stack