What’s Vulnerable › Vulnerabilities
CVE-2016-10714
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-27 · updated 2026-06-17
- Weakness: CWE-189
Description
In zsh before 5.3, an off-by-one error resulted in undersized buffers that were intended to support PATH_MAX characters.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- zsh: before 5.3 — fixed in 5.3
How to fix
Upgrade to a fixed version: zsh 5.3. Check the vendor advisory for mitigations.
References
- https://sourceforge.net/p/zsh/code/ci/a62e1640bcafbb82d86ea8d8ce057a83c4683d60
- https://usn.ubuntu.com/3593-1/
- https://sourceforge.net/p/zsh/code/ci/a62e1640bcafbb82d86ea8d8ce057a83c4683d60
- https://usn.ubuntu.com/3593-1/
Get alerted when CVE-2016-10714 or the next vulnerability affects your stack