What’s Vulnerable › Vulnerabilities
CVE-2016-10724
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-05 · updated 2026-06-17
- Weakness: CWE-400
Description
Bitcoin Core before v0.13.0 allows denial of service (memory exhaustion) triggered by the remote network alert system (deprecated since Q1 2016) if an attacker can sign a message with a certain private key that had been known by unintended actors, because of an infinitely sized map. This affects other uses of the codebase, such as Bitcoin Knots before v0.13.0.knots20160814 and many altcoins.
Affected products
- Bitcoin-Qt: before 0.13.0 — fixed in 0.13.0
- Bitcoin Core: before 0.13.0 — fixed in 0.13.0
- Bitcoind: before 0.13.0 — fixed in 0.13.0
How to fix
Upgrade to a fixed version: Bitcoin-Qt 0.13.0; Bitcoin Core 0.13.0; Bitcoind 0.13.0. Check the vendor advisory for mitigations.
References
- https://bitcoin.org/en/posts/alert-key-and-vulnerabilities-disclosure
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
- https://github.com/JinBean/CVE-Extension
- https://lists.linuxfoundation.org/pipermail/bitcoin-dev/2018-July/016189.html
- https://bitcoin.org/en/posts/alert-key-and-vulnerabilities-disclosure
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
- https://github.com/JinBean/CVE-Extension
- https://lists.linuxfoundation.org/pipermail/bitcoin-dev/2018-July/016189.html
Get alerted when CVE-2016-10724 or the next vulnerability affects your stack