What’s Vulnerable › Vulnerabilities
CVE-2016-10735
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-09 · updated 2026-06-17
- Weakness: CWE-79
Description
In Bootstrap 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute, a different vulnerability than CVE-2018-14041.
Affected products
- Getbootstrap Bootstrap: from 3.0.0 before 3.4.0; 4.0.0-beta — fixed in 3.4.0
How to fix
Upgrade to a fixed version: Getbootstrap Bootstrap 3.4.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHBA-2019:1076
- https://access.redhat.com/errata/RHBA-2019:1570
- https://access.redhat.com/errata/RHSA-2019:1456
- https://access.redhat.com/errata/RHSA-2019:3023
- https://access.redhat.com/errata/RHSA-2020:0132
- https://access.redhat.com/errata/RHSA-2020:0133
- https://blog.getbootstrap.com/2018/12/13/bootstrap-3-4-0/
- https://github.com/twbs/bootstrap/issues/20184
- https://github.com/twbs/bootstrap/issues/27915#issuecomment-452140906
- https://github.com/twbs/bootstrap/pull/23679
- https://github.com/twbs/bootstrap/pull/23687
- https://github.com/twbs/bootstrap/pull/26460
Get alerted when CVE-2016-10735 or the next vulnerability affects your stack