What’s Vulnerable › Vulnerabilities
CVE-2016-10736
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The "Social Pug - Easy Social Share Buttons" plugin before 1.2.6 for WordPress allows XSS via the wp-admin/admin.php?page=dpsp-toolkit dpsp_message_class parameter.
Affected products
- Devpups Social Pug: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: Devpups Social Pug 1.2.6. Check the vendor advisory for mitigations.
References
- https://advisories.dxw.com/advisories/reflected-xss-in-social-pug-easy-social-share-buttons-could-allow-an-attacker-to-do-almost-anything-an-admin-user-can/
- https://advisories.dxw.com/advisories/reflected-xss-in-social-pug-easy-social-share-buttons-could-allow-an-attacker-to-do-almost-anything-an-admin-user-can/
Get alerted when CVE-2016-10736 or the next vulnerability affects your stack