What’s Vulnerable › Vulnerabilities
CVE-2016-10743
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-23 · updated 2026-06-17
- Weakness: CWE-332
Description
hostapd before 2.6 does not prevent use of the low-quality PRNG that is reached by an os_random() function call.
Affected products
- w1.fi hostapd: before 2.6 — fixed in 2.6
How to fix
Upgrade to a fixed version: w1.fi hostapd 2.6. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/156573/Hostapd-Insufficient-Entropy.html
- http://seclists.org/fulldisclosure/2020/Feb/26
- http://www.openwall.com/lists/oss-security/2020/02/27/1
- http://www.openwall.com/lists/oss-security/2020/02/27/2
- https://lists.debian.org/debian-lts-announce/2019/03/msg00035.html
- https://usn.ubuntu.com/3944-1/
- https://w1.fi/cgit/hostap/commit/?id=98a516eae8260e6fd5c48ddecf8d006285da7389
- http://packetstormsecurity.com/files/156573/Hostapd-Insufficient-Entropy.html
- http://seclists.org/fulldisclosure/2020/Feb/26
- http://www.openwall.com/lists/oss-security/2020/02/27/1
- http://www.openwall.com/lists/oss-security/2020/02/27/2
- https://lists.debian.org/debian-lts-announce/2019/03/msg00035.html
Get alerted when CVE-2016-10743 or the next vulnerability affects your stack