What’s Vulnerable › Vulnerabilities
CVE-2016-10746
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-18 · updated 2026-06-17
- Weakness: CWE-254
Description
libvirt-domain.c in libvirt before 1.3.1 supports virDomainGetTime API calls by guest agents with an RO connection, even though an RW connection was supposed to be required, a different vulnerability than CVE-2019-3886.
Affected products
- Debian Linux: 8.0
- libvirt: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: libvirt 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/libvirt/libvirt/commit/506e9d6c2d4baaf580d489fff0690c0ff2ff588f
- https://github.com/libvirt/libvirt/compare/11288f5...8fd6867
- https://lists.debian.org/debian-lts-announce/2019/04/msg00032.html
- https://github.com/libvirt/libvirt/commit/506e9d6c2d4baaf580d489fff0690c0ff2ff588f
- https://github.com/libvirt/libvirt/compare/11288f5...8fd6867
- https://lists.debian.org/debian-lts-announce/2019/04/msg00032.html
Get alerted when CVE-2016-10746 or the next vulnerability affects your stack