What’s Vulnerable › Vulnerabilities
CVE-2016-10764
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-27 · updated 2026-06-17
- Weakness: CWE-119
Description
In the Linux kernel before 4.9.6, there is an off by one in the drivers/mtd/spi-nor/cadence-quadspi.c cqspi_setup_flash() function. There are CQSPI_MAX_CHIPSELECT elements in the ->f_pdata array so the ">" should be ">=" instead.
Affected products
- Linux kernel: from 4.8 before 4.9.6 — fixed in 4.9.6
How to fix
Upgrade to a fixed version: Linux kernel 4.9.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=193e87143c290ec16838f5368adc0e0bc94eb931
- https://github.com/torvalds/linux/commit/193e87143c290ec16838f5368adc0e0bc94eb931
- https://mirrors.edge.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.9.6
- https://support.f5.com/csp/article/K24444495
- https://support.f5.com/csp/article/K24444495?utm_source=f5support&%3Butm_medium=RSS
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=193e87143c290ec16838f5368adc0e0bc94eb931
- https://github.com/torvalds/linux/commit/193e87143c290ec16838f5368adc0e0bc94eb931
- https://mirrors.edge.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.9.6
- https://support.f5.com/csp/article/K24444495
- https://support.f5.com/csp/article/K24444495?utm_source=f5support&%3Butm_medium=RSS
Get alerted when CVE-2016-10764 or the next vulnerability affects your stack