What’s Vulnerable › Vulnerabilities
CVE-2016-10823
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-01 · updated 2026-06-17
- Weakness: CWE-20
Description
cPanel before 55.9999.141 allows arbitrary code execution in the context of the root account because of MakeText interpolation (SEC-89).
Affected products
- WebPros cPanel: from 11.50.0.4 before 11.50.5.2; from 11.51.9999.98 before 11.52.4.1; from 11.54.0.0 before 11.54.0.20; from 55.9999.61 before 55.9999.141 — fixed in 11.50.5.2, 11.52.4.1, 11.54.0.20, 55.9999.141
How to fix
Upgrade to a fixed version: WebPros cPanel 11.50.5.2, 11.52.4.1, 11.54.0.20, 55.9999.141. Check the vendor advisory for mitigations.
References
- https://documentation.cpanel.net/display/CL/56+Change+Log
- https://documentation.cpanel.net/display/CL/56+Change+Log
Get alerted when CVE-2016-10823 or the next vulnerability affects your stack