What’s Vulnerable › Vulnerabilities
CVE-2016-10855
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-01 · updated 2026-06-17
- Weakness: CWE-20
Description
cPanel before 11.54.0.4 allows unauthenticated arbitrary code execution via cpsrvd (SEC-91).
Affected products
- WebPros cPanel: from 11.48.0.5 before 11.48.5.2; from 11.50.0.4 before 11.50.4.3; from 11.52.2.1 before 11.52.2.4; from 11.54.0.0 before 11.54.0.4 — fixed in 11.48.5.2, 11.50.4.3, 11.52.2.4, 11.54.0.4
How to fix
Upgrade to a fixed version: WebPros cPanel 11.48.5.2, 11.50.4.3, 11.52.2.4, 11.54.0.4. Check the vendor advisory for mitigations.
References
- https://documentation.cpanel.net/display/CL/54+Change+Log
- https://forums.cpanel.net/threads/cpanel-tsr-2016-0001-full-disclosure.522571/
- https://documentation.cpanel.net/display/CL/54+Change+Log
Get alerted when CVE-2016-10855 or the next vulnerability affects your stack