What’s Vulnerable › Vulnerabilities
CVE-2016-10867
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The all-in-one-wp-security-and-firewall plugin before 4.0.6 for WordPress has XSS in settings pages.
Affected products
- All In One WP Security & Firewall Team All-In-One Security (AIOS) – Security and Firewall (WordPress plugin): before 4.0.6 — fixed in 4.0.6
How to fix
Upgrade to a fixed version: All In One WP Security & Firewall Team All-In-One Security (AIOS) – Security and Firewall (WordPress plugin) 4.0.6. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/#developers
- https://wpvulndb.com/vulnerabilities/9736
- https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/#developers
- https://wpvulndb.com/vulnerabilities/9736
Get alerted when CVE-2016-10867 or the next vulnerability affects your stack