What’s Vulnerable › Vulnerabilities
CVE-2016-10893
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The crayon-syntax-highlighter plugin before 2.8.4 for WordPress has multiple XSS issues via AJAX requests.
Affected products
- Aram Kocharyan Crayon Syntax Highlighter: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: Aram Kocharyan Crayon Syntax Highlighter 2.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/aramk/crayon-syntax-highlighter/commit/7fdb2e6b4c65178b4ed01ff08a8a38afe5a5151e
- https://github.com/aramk/crayon-syntax-highlighter/issues/347
- https://wordpress.org/plugins/crayon-syntax-highlighter/#developers
- https://github.com/aramk/crayon-syntax-highlighter/commit/7fdb2e6b4c65178b4ed01ff08a8a38afe5a5151e
- https://github.com/aramk/crayon-syntax-highlighter/issues/347
- https://wordpress.org/plugins/crayon-syntax-highlighter/#developers
Get alerted when CVE-2016-10893 or the next vulnerability affects your stack