What’s Vulnerable › Vulnerabilities
CVE-2016-10905
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-19 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in fs/gfs2/rgrp.c in the Linux kernel before 4.8. A use-after-free is caused by the functions gfs2_clear_rgrpd and read_rindex_entry.
Affected products
- Linux kernel: before 4.8; from 3.4 before 3.16.74; from 3.17 before 4.4.191; from 4.5 before 4.8 — fixed in 3.16.74, 4.4.191, 4.8
How to fix
Upgrade to a fixed version: Linux kernel 3.16.74, 4.4.191, 4.8. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/154951/Kernel-Live-Patch-Security-Notice-LSN-0058-1.html
- http://packetstormsecurity.com/files/155212/Slackware-Security-Advisory-Slackware-14.2-kernel-Updates.html
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=36e4ad0316c017d5b271378ed9a1c9a4b77fab5f
- https://lists.debian.org/debian-lts-announce/2019/09/msg00025.html
- https://seclists.org/bugtraq/2019/Nov/11
- https://support.f5.com/csp/article/K31332013
- https://support.f5.com/csp/article/K31332013?utm_source=f5support&%3Butm_medium=RSS
- https://usn.ubuntu.com/4145-1/
- http://packetstormsecurity.com/files/154951/Kernel-Live-Patch-Security-Notice-LSN-0058-1.html
- http://packetstormsecurity.com/files/155212/Slackware-Security-Advisory-Slackware-14.2-kernel-Updates.html
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=36e4ad0316c017d5b271378ed9a1c9a4b77fab5f
- https://lists.debian.org/debian-lts-announce/2019/09/msg00025.html
Get alerted when CVE-2016-10905 or the next vulnerability affects your stack