What’s Vulnerable › Vulnerabilities
CVE-2016-10907
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-19 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in drivers/iio/dac/ad5755.c in the Linux kernel before 4.8.6. There is an out of bounds write in the function ad5755_parse_dt.
Affected products
- Linux kernel: before 4.8.6 — fixed in 4.8.6
How to fix
Upgrade to a fixed version: Linux kernel 4.8.6. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.6
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=9d47964bfd471f0dd4c89f28556aec68bffa0020
- https://support.f5.com/csp/article/K79609038
- https://support.f5.com/csp/article/K79609038?utm_source=f5support&%3Butm_medium=RSS
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.6
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=9d47964bfd471f0dd4c89f28556aec68bffa0020
- https://support.f5.com/csp/article/K79609038
- https://support.f5.com/csp/article/K79609038?utm_source=f5support&%3Butm_medium=RSS
Get alerted when CVE-2016-10907 or the next vulnerability affects your stack