What’s Vulnerable › Vulnerabilities
CVE-2016-10931
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-26 · updated 2026-06-17
- Weakness: CWE-295
Description
An issue was discovered in the openssl crate before 0.9.0 for Rust. There is an SSL/TLS man-in-the-middle vulnerability because certificate verification is off by default and there is no API for hostname verification.
Affected products
- rust-openssl: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: rust-openssl 0.9.0. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2016-0001.html
- https://rustsec.org/advisories/RUSTSEC-2016-0001.html
Get alerted when CVE-2016-10931 or the next vulnerability affects your stack