What’s Vulnerable › Vulnerabilities
CVE-2016-10950
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-13 · updated 2026-06-17
- Weakness: CWE-89
Description
The sirv plugin before 1.3.2 for WordPress has SQL injection via the id parameter.
Affected products
- sirv Image Optimizer, Resizer and CDN – Sirv: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: sirv Image Optimizer, Resizer and CDN – Sirv 1.3.2. Check the vendor advisory for mitigations.
References
- http://lenonleite.com.br/en/2016/11/10/sirv-1-3-1-plugin-for-wordpress/
- https://wordpress.org/plugins/sirv/#developers
- https://wpvulndb.com/vulnerabilities/8673
- http://lenonleite.com.br/en/2016/11/10/sirv-1-3-1-plugin-for-wordpress/
- https://wordpress.org/plugins/sirv/#developers
- https://wpvulndb.com/vulnerabilities/8673
Get alerted when CVE-2016-10950 or the next vulnerability affects your stack