What’s Vulnerable › Vulnerabilities
CVE-2016-10985
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The echosign plugin before 1.2 for WordPress has XSS via the templates/add_templates.php id parameter.
Affected products
- smackcoders Echo Sign: before 1.2 — fixed in 1.2
How to fix
Upgrade to a fixed version: smackcoders Echo Sign 1.2. Check the vendor advisory for mitigations.
References
- https://0x62626262.wordpress.com/2016/04/21/echosign-plugin-for-wordpress-xss-vulnerability/
- https://wordpress.org/plugins/echosign/#developers
- https://wpvulndb.com/vulnerabilities/8465
- https://0x62626262.wordpress.com/2016/04/21/echosign-plugin-for-wordpress-xss-vulnerability/
- https://wordpress.org/plugins/echosign/#developers
- https://wpvulndb.com/vulnerabilities/8465
Get alerted when CVE-2016-10985 or the next vulnerability affects your stack