What’s Vulnerable › Vulnerabilities
CVE-2016-11021: D-Link DCS-930L Devices OS Command Injection Vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-25
- EPSS: 69.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-09 · updated 2026-06-17
- Weakness: CWE-78
Description
setSystemCommand on D-Link DCS-930L devices before 2.12 allows a remote attacker to execute code via an OS command in the SystemCommand parameter.
Affected products
- D-Link DCS-930L: before 2.12 — fixed in 2.12
How to fix
Upgrade to a fixed version: D-Link DCS-930L 2.12. Check the vendor advisory for mitigations.
References
- https://www.exploit-db.com/exploits/39437
- https://www.exploit-db.com/exploits/39437
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2016-11021
Get alerted when CVE-2016-11021 or the next vulnerability affects your stack