What’s Vulnerable › Vulnerabilities
CVE-2016-11058
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-28 · updated 2026-06-17
- Weakness: CWE-613
Description
The NETGEAR genie application before 2.4.34 for Android is affected by mishandling of hard-coded API keys and session IDs.
Affected products
- NETGEAR Genie: before 2.4.34 — fixed in 2.4.34
How to fix
Upgrade to a fixed version: NETGEAR Genie 2.4.34. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/30922/NETGEAR-genie-App-for-Android-Hard-coded-API-Key-and-Session-ID-Vulnerability
- https://kb.netgear.com/30922/NETGEAR-genie-App-for-Android-Hard-coded-API-Key-and-Session-ID-Vulnerability
Get alerted when CVE-2016-11058 or the next vulnerability affects your stack