What’s Vulnerable › Vulnerabilities

CVE-2016-1252

Description

The apt package in Debian jessie before 1.0.9.8.4, in Debian unstable before 1.4~beta2, in Ubuntu 14.04 LTS before 1.0.1ubuntu2.17, in Ubuntu 16.04 LTS before 1.2.15ubuntu0.2, and in Ubuntu 16.10 before 1.3.2ubuntu0.1 allows man-in-the-middle attackers to bypass a repository-signing protection mechanism by leveraging improper error handling when validating InRelease file signatures.

Affected products

How to fix

Upgrade to a fixed version: Debian Advanced Package Tool 1.0.9.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-1252 or the next vulnerability affects your stack