What’s Vulnerable › Vulnerabilities
CVE-2016-1254
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-05 · updated 2026-06-17
- Weakness: CWE-119
Description
Tor before 0.2.8.12 might allow remote attackers to cause a denial of service (client crash) via a crafted hidden service descriptor.
Affected products
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 24, 25
- openSUSE Leap: 42.2
- Opensuse: 13.2
- Opensuse Project Leap: 42.1
- torproject Tor: before 0.2.8.12 — fixed in 0.2.8.12
How to fix
Upgrade to a fixed version: torproject Tor 0.2.8.12. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2016-12/msg00154.html
- http://lists.opensuse.org/opensuse-updates/2016-12/msg00155.html
- https://blog.torproject.org/blog/tor-02812-released
- https://gitweb.torproject.org/tor.git/commit/?id=d978216dea6b21ac38230a59d172139185a68dbd
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FXOJSMCTIOHLBRYFBVEL3CDLGPZXX6WE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GTU2R253477RZLYAJAR5DAXAON7KIVLA/
- https://trac.torproject.org/projects/tor/ticket/21018
- https://www.debian.org/security/2016/dsa-3741
- http://lists.opensuse.org/opensuse-updates/2016-12/msg00154.html
- http://lists.opensuse.org/opensuse-updates/2016-12/msg00155.html
- https://blog.torproject.org/blog/tor-02812-released
- https://gitweb.torproject.org/tor.git/commit/?id=d978216dea6b21ac38230a59d172139185a68dbd
Get alerted when CVE-2016-1254 or the next vulnerability affects your stack