What’s Vulnerable › Vulnerabilities
CVE-2016-1487
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-09 · updated 2026-06-17
- Weakness: CWE-502
Description
Lexmark Markvision Enterprise before 2.3.0 misuses the Apache Commons Collections Library, leading to remote code execution because of Java deserialization.
Affected products
- Lexmark Markvision Enterprise: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Lexmark Markvision Enterprise 2.3.0. Check the vendor advisory for mitigations.
References
- http://support.lexmark.com/index?page=content&id=TE747&locale=EN&userlocale=EN_US
- http://support.lexmark.com/index?page=content&id=TE747&locale=EN&userlocale=EN_US
Get alerted when CVE-2016-1487 or the next vulnerability affects your stack