What’s Vulnerable › Vulnerabilities
CVE-2016-15018: krail-jpa sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-15 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability was found in krail-jpa up to 0.9.1. It has been classified as critical. This affects an unknown part. The manipulation leads to sql injection. Upgrading to version 0.9.2 is able to address this issue. The identifier of the patch is c1e848665492e21ef6cc9be443205e36b9a1f6be. It is recommended to upgrade the affected component. The identifier VDB-218373 was assigned to this vulnerability.
Affected products
- krail-jpa: before 0.9.2 — fixed in 0.9.2
How to fix
Upgrade to a fixed version: krail-jpa 0.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/KrailOrg/krail-jpa/commit/c1e848665492e21ef6cc9be443205e36b9a1f6be
- https://github.com/KrailOrg/krail-jpa/issues/18
- https://github.com/KrailOrg/krail-jpa/releases/tag/0.9.2
- https://vuldb.com/?ctiid.218373
- https://vuldb.com/?id.218373
- https://github.com/KrailOrg/krail-jpa/commit/c1e848665492e21ef6cc9be443205e36b9a1f6be
- https://github.com/KrailOrg/krail-jpa/issues/18
- https://github.com/KrailOrg/krail-jpa/releases/tag/0.9.2
- https://vuldb.com/?ctiid.218373
- https://vuldb.com/?id.218373
Get alerted when CVE-2016-15018 or the next vulnerability affects your stack