What’s Vulnerable › Vulnerabilities
CVE-2016-15020: liftkit database Query.php processOrderBy sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-16 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The patch is named 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.
Affected products
- liftkit database: before 2.13.2 — fixed in 2.13.2
How to fix
Upgrade to a fixed version: liftkit database 2.13.2. Check the vendor advisory for mitigations.
References
- https://github.com/liftkit/database/commit/42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a
- https://github.com/liftkit/database/releases/tag/v2.13.2
- https://vuldb.com/?ctiid.218391
- https://vuldb.com/?id.218391
- https://github.com/liftkit/database/commit/42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a
- https://github.com/liftkit/database/releases/tag/v2.13.2
- https://vuldb.com/?ctiid.218391
- https://vuldb.com/?id.218391
Get alerted when CVE-2016-15020 or the next vulnerability affects your stack