What’s Vulnerable › Vulnerabilities
CVE-2016-1544
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-06 · updated 2026-06-17
- Weakness: CWE-400
Description
nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).
Affected products
- Fedoraproject Fedora: 22, 23
- nghttp2: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: nghttp2 1.7.1. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/177308.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/177666.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1308461
- https://github.com/nghttp2/nghttp2/compare/v1.7.0...v1.7.1
- https://github.com/nghttp2/nghttp2/releases/tag/v1.7.1
- https://security.gentoo.org/glsa/201612-13
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/177308.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/177666.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1308461
- https://github.com/nghttp2/nghttp2/compare/v1.7.0...v1.7.1
- https://github.com/nghttp2/nghttp2/releases/tag/v1.7.1
- https://security.gentoo.org/glsa/201612-13
Get alerted when CVE-2016-1544 or the next vulnerability affects your stack