What’s Vulnerable › Vulnerabilities
CVE-2016-1585: AppArmor mount rules grant excessive permissions
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-22 · updated 2026-06-17
Description
In all versions of AppArmor mount rules are accidentally widened when compiled.
Affected products
- apparmor: before 2.13.10; from 3.0.0 before 3.0.12; from 3.1.0 before 3.1.6 — fixed in 2.13.10, 3.0.12, 3.1.6
How to fix
Upgrade to a fixed version: apparmor 2.13.10, 3.0.12, 3.1.6. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/apparmor/+bug/1597017
- https://lists.apache.org/thread.html/rf9fa47ab66495c78bb4120b0754dd9531ca2ff0430f6685ac9b07772%40%3Cdev.mina.apache.org%3E
- https://bugs.launchpad.net/apparmor/+bug/1597017
- https://lists.apache.org/thread.html/rf9fa47ab66495c78bb4120b0754dd9531ca2ff0430f6685ac9b07772%40%3Cdev.mina.apache.org%3E
Get alerted when CVE-2016-1585 or the next vulnerability affects your stack