What’s Vulnerable › Vulnerabilities
CVE-2016-1646: Google Chromium V8 Out-of-Bounds Read Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-06-08
- EPSS: 48.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-03-29 · updated 2026-06-17
- Weakness: CWE-125
Description
The Array.prototype.concat implementation in builtins.cc in Google V8, as used in Google Chrome before 49.0.2623.108, does not properly consider element data types, which allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via crafted JavaScript code.
Affected products
- Canonical Ubuntu Linux: 14.04, 15.10, 16.04
- Debian Linux: 8.0, 9.0
- Google Chrome: before 49.0.2623.108 — fixed in 49.0.2623.108
- openSUSE Leap: 42.1
- Opensuse: 13.1
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Eus: 6.7
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Workstation: 6.0
- SUSE Package Hub: all versions
How to fix
Upgrade to a fixed version: Google Chrome 49.0.2623.108. Check the vendor advisory for mitigations.
References
- http://googlechromereleases.blogspot.com/2016/03/stable-channel-update_24.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00039.html
- http://rhn.redhat.com/errata/RHSA-2016-0525.html
- http://www.debian.org/security/2016/dsa-3531
- http://www.securitytracker.com/id/1035423
- http://www.ubuntu.com/usn/USN-2955-1
- https://code.google.com/p/chromium/issues/detail?id=594574
- https://codereview.chromium.org/1804963002/
- https://security.gentoo.org/glsa/201605-02
- http://googlechromereleases.blogspot.com/2016/03/stable-channel-update_24.html
Get alerted when CVE-2016-1646 or the next vulnerability affects your stack