What’s Vulnerable › Vulnerabilities
CVE-2016-1669
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-05-14 · updated 2026-06-17
- Weakness: CWE-119
Description
The Zone::New function in zone.cc in Google V8 before 5.0.71.47, as used in Google Chrome before 50.0.2661.102, does not properly determine when to expand certain memory allocations, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via crafted JavaScript code.
Affected products
- Canonical Ubuntu Linux: 14.04, 15.10, 16.04
- Debian Linux: 8.0
- Google Chrome: through 50.0.2661.87
- Google V8: through 5.0.71
- Node.js: from 0.10.0 before 0.10.46; from 0.12.0 before 0.12.15; from 4.0.0 through 4.1.2; from 4.2.0 before 4.4.6; from 5.0.0 before 5.12.0; from 6.0.0 through 6.2.0 — fixed in 0.10.46, 0.12.15, 4.4.6, 5.12.0
- Opensuse: 13.1
How to fix
Upgrade to a fixed version: Node.js 0.10.46, 0.12.15, 4.4.6, 5.12.0. Check the vendor advisory for mitigations.
References
- http://googlechromereleases.blogspot.com/2016/05/stable-channel-update.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00043.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00050.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00048.html
- http://lists.opensuse.org/opensuse-updates/2016-07/msg00063.html
- http://rhn.redhat.com/errata/RHSA-2016-1080.html
- http://rhn.redhat.com/errata/RHSA-2017-0002.html
- http://www.debian.org/security/2016/dsa-3590
- http://www.securityfocus.com/bid/90584
- http://www.securitytracker.com/id/1035872
- http://www.ubuntu.com/usn/USN-2960-1
- https://access.redhat.com/errata/RHSA-2017:0879
Get alerted when CVE-2016-1669 or the next vulnerability affects your stack