What’s Vulnerable › Vulnerabilities
CVE-2016-20010
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
Description
EWWW Image Optimizer before 2.8.5 allows remote command execution because it relies on a protection mechanism involving boolval, which is unavailable before PHP 5.5.
Affected products
- nosilver4u EWWW Image Optimizer: before 2.8.5 — fixed in 2.8.5
How to fix
Upgrade to a fixed version: nosilver4u EWWW Image Optimizer 2.8.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ewww-image-optimizer/trunk/changelog.txt
- https://www.wordfence.com/blog/2016/06/vulnerability-ewww-image-optimizer/
- https://plugins.trac.wordpress.org/browser/ewww-image-optimizer/trunk/changelog.txt
- https://www.wordfence.com/blog/2016/06/vulnerability-ewww-image-optimizer/
Get alerted when CVE-2016-20010 or the next vulnerability affects your stack