What’s Vulnerable › Vulnerabilities
CVE-2016-2004
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 94.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-04-21 · updated 2026-06-17
- Weakness: CWE-306
Description
HPE Data Protector before 7.03_108, 8.x before 8.15, and 9.x before 9.06 allow remote attackers to execute arbitrary code via unspecified vectors related to lack of authentication. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-2623.
Affected products
- Hewlett Packard Enterprise Data Protector: from 7.0 before 7.03_108; from 8.0 before 8.15; from 9.0 before 9.06 — fixed in 7.03_108, 8.15, 9.06
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise Data Protector 7.03_108, 8.15, 9.06. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/137199/HP-Data-Protector-A.09.00-Command-Execution.html
- http://packetstormsecurity.com/files/137341/HP-Data-Protector-Encrypted-Communication-Remote-Command-Execution.html
- http://www.kb.cert.org/vuls/id/267328
- http://www.securitytracker.com/id/1035631
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05085988
- https://www.exploit-db.com/exploits/39858/
- https://www.exploit-db.com/exploits/39874/
- http://packetstormsecurity.com/files/137199/HP-Data-Protector-A.09.00-Command-Execution.html
- http://packetstormsecurity.com/files/137341/HP-Data-Protector-Encrypted-Communication-Remote-Command-Execution.html
- http://www.kb.cert.org/vuls/id/267328
- http://www.securitytracker.com/id/1035631
- https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05085988
Get alerted when CVE-2016-2004 or the next vulnerability affects your stack