What’s Vulnerable › Vulnerabilities
CVE-2016-20098: Moderator Toolbox before 4.0.14 Stored XSS via Removal Reasons Configuration
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-09 · updated 2026-10-09
- Weakness: CWE-79
Description
Moderator Toolbox (reddit-moderator-toolbox) before 4.0.14 contains a stored cross-site scripting vulnerability in the removalreasons module, which inserts subreddit toolbox wiki fields into popup HTML without encoding. Attackers who can edit the toolbox wiki page can plant JavaScript in fields like pmsubject, header, or reason titles to act with moderators' Reddit sessions.
Affected products
- toolbox-team reddit-moderator-toolbox: before 4.0.14 — fixed in 4.0.14
How to fix
Upgrade to a fixed version: toolbox-team reddit-moderator-toolbox 4.0.14. Check the vendor advisory for mitigations.
References
- https://github.com/toolbox-team/reddit-moderator-toolbox
- https://github.com/toolbox-team/reddit-moderator-toolbox/commit/26f45ba21d84cecb92b1a820896ad3bf5254376e
- https://www.vulncheck.com/advisories/moderator-toolbox-before-4.0.14-stored-xss-via-removal-reasons-configuration
Get alerted when CVE-2016-20098 or the next vulnerability affects your stack