What’s Vulnerable › Vulnerabilities
CVE-2016-20103: Cherry Plugin for WordPress < 1.2.7 Path Traversal via download-content.php
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-22
- Weakness: CWE-22
Description
Cherry Plugin for WordPress before 1.2.7 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files via the 'file' parameter. Attackers can send GET requests to /admin/import-export/download-content.php with traversal sequences like ../../../../../wp-config.php to read database credentials, since the script passes input directly to readfile(). Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Affected products
- Cherry Team Cherry Plugin: from 1.1 before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: Cherry Team Cherry Plugin 1.2.7. Check the vendor advisory for mitigations.
References
- https://github.com/CherryFramework/cherry-plugin/commit/69a3f7b
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/cherry-file-download.yaml
- https://wpscan.com/vulnerability/90034817-dee7-40c9-80a2-1f1cd1d033ee
- https://www.vulncheck.com/advisories/cherry-plugin-for-wordpress-1.2.7-path-traversal-via-download-content-php
Get alerted when CVE-2016-20103 or the next vulnerability affects your stack