What’s Vulnerable › Vulnerabilities
CVE-2016-2047
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2016-01-27 · updated 2026-06-17
- Weakness: CWE-254
Description
The ssl_verify_server_cert function in sql-common/client.c in MariaDB before 5.5.47, 10.0.x before 10.0.23, and 10.1.x before 10.1.10; Oracle MySQL 5.5.48 and earlier, 5.6.29 and earlier, and 5.7.11 and earlier; and Percona Server do not properly verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via a "/CN=" string in a field in a certificate, as demonstrated by "/OU=/CN=bar.com/CN=foo.com."
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- Debian Linux: 8.0, 9.0
- MariaDB: from 5.5.20 before 5.5.47; from 10.0.0 before 10.0.23; from 10.1.0 before 10.1.10 — fixed in 10.0.23, 10.1.10, 5.5.47
- openSUSE Leap: 42.1
- Oracle Corporation Oracle Linux: 7
- MySQL Server: from 5.5.0 through 5.5.48; from 5.6.0 through 5.6.29; from 5.7.0 through 5.7.11
- Red Hat Enterprise Linux: 6.0, 7.0
How to fix
Upgrade to a fixed version: MariaDB 10.0.23, 10.1.10, 5.5.47. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00053.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00034.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00051.html
- http://lists.opensuse.org/opensuse-security-announce/2016-06/msg00053.html
- http://rhn.redhat.com/errata/RHSA-2016-0534.html
- http://rhn.redhat.com/errata/RHSA-2016-0705.html
- http://rhn.redhat.com/errata/RHSA-2016-1480.html
- http://rhn.redhat.com/errata/RHSA-2016-1481.html
- http://www.debian.org/security/2016/dsa-3453
- http://www.debian.org/security/2016/dsa-3557
Get alerted when CVE-2016-2047 or the next vulnerability affects your stack