What’s Vulnerable › Vulnerabilities
CVE-2016-2090
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-13 · updated 2026-06-17
- Weakness: CWE-119
Description
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.04
- Debian Linux: 8.0
- Fedoraproject Fedora: 24, 25
- Freedesktop Libbsd: before 0.8.2 — fixed in 0.8.2
How to fix
Upgrade to a fixed version: Freedesktop Libbsd 0.8.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2016/01/28/5
- https://blog.fuzzing-project.org/36-Heap-buffer-overflow-in-fgetwln-function-of-libbsd.html
- https://bugs.freedesktop.org/show_bug.cgi?id=93881
- https://cgit.freedesktop.org/libbsd/commit/?id=c8f0723d2b4520bdd6b9eb7c3e7976de726d7ff7
- https://lists.debian.org/debian-lts-announce/2019/12/msg00036.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7KJE5SPSX7HEKLZ34LUTZLXWPEL2K353/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DIQKQ42Z7553D46QY3IMIQKS52QTNIHY/
- https://security.gentoo.org/glsa/201607-13
- https://usn.ubuntu.com/4243-1/
- http://www.openwall.com/lists/oss-security/2016/01/28/5
- https://blog.fuzzing-project.org/36-Heap-buffer-overflow-in-fgetwln-function-of-libbsd.html
- https://bugs.freedesktop.org/show_bug.cgi?id=93881
Get alerted when CVE-2016-2090 or the next vulnerability affects your stack