What’s Vulnerable › Vulnerabilities

CVE-2016-2105

Description

Integer overflow in the EVP_EncodeUpdate function in crypto/evp/encode.c in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h allows remote attackers to cause a denial of service (heap memory corruption) via a large amount of binary data.

Affected products

How to fix

Upgrade to a fixed version: Node.js 0.10.45, 0.12.14, 4.4.4, 5.11.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-2105 or the next vulnerability affects your stack