What’s Vulnerable › Vulnerabilities
CVE-2016-2107
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 89.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2016-05-05 · updated 2026-06-17
- Weakness: CWE-200
Description
The AES-NI implementation in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h does not consider memory allocation during a certain padding check, which allows remote attackers to obtain sensitive cleartext information via a padding-oracle attack against an AES CBC session. NOTE: this vulnerability exists because of an incorrect fix for CVE-2013-0169.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 15.10, 16.04
- Debian Linux: 8.0
- Android: 4.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.1 (+14)
- HP Helion Openstack: 2.0.0, 2.1.0, 2.1.2, 2.1.4
- Node.js: from 0.10.0 before 0.10.45; from 0.12.0 before 0.12.14; from 4.0.0 through 4.1.2; from 4.2.0 before 4.4.4; from 5.0.0 before 5.11.1; 6.0.0 — fixed in 0.10.45, 0.12.14, 4.4.4, 5.11.1
- OpenSSL: through 1.0.1s; 1.0.2, 1.0.2-beta1, 1.0.2-beta2, 1.0.2-beta3, 1.0.2a, 1.0.2b (+5)
- openSUSE Leap: 42.1
- Opensuse: 13.2
- RedHat Enterprise Linux Desktop: 7.0, 6.0
- RedHat Enterprise Linux Hpc Node: 7.0, 6.0
- RedHat Enterprise Linux Hpc Node Eus: 7.2
- RedHat Enterprise Linux Server: 7.0, 6.0
- RedHat Enterprise Linux Server Aus: 7.2
- RedHat Enterprise Linux Server Eus: 7.2
- RedHat Enterprise Linux Workstation: 7.0, 6.0
How to fix
Upgrade to a fixed version: Node.js 0.10.45, 0.12.14, 4.4.4, 5.11.1. Check the vendor advisory for mitigations.
References
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10759
- http://lists.apple.com/archives/security-announce/2016/Jul/msg00000.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-May/183457.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-May/183607.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-May/184605.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00011.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00013.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00014.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00019.html
Get alerted when CVE-2016-2107 or the next vulnerability affects your stack