What’s Vulnerable › Vulnerabilities
CVE-2016-2123
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-01 · updated 2026-06-17
- Weakness: CWE-122
Description
A flaw was found in samba versions 4.0.0 to 4.5.2. The Samba routine ndr_pull_dnsp_name contains an integer wrap problem, leading to an attacker-controlled memory overwrite. ndr_pull_dnsp_name parses data from the Samba Active Directory ldb database. Any user who can write to the dnsRecord attribute over LDAP can trigger this memory corruption. By default, all authenticated LDAP users can write to the dnsRecord attribute on new DNS objects. This makes the defect a remote privilege escalation.
Affected products
- Samba: from 4.0.0 through 4.0.26; from 4.1.0 through 4.1.23; from 4.2.0 through 4.2.14; from 4.3.0 before 4.3.13; from 4.4.0 before 4.4.8; from 4.5.0 before 4.5.3 — fixed in 4.3.13, 4.4.8, 4.5.3
How to fix
Upgrade to a fixed version: Samba 4.3.13, 4.4.8, 4.5.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/94970
- http://www.securitytracker.com/id/1037493
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-2123
- https://www.samba.org/samba/security/CVE-2016-2123.html
- http://www.securityfocus.com/bid/94970
- http://www.securitytracker.com/id/1037493
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-2123
- https://www.samba.org/samba/security/CVE-2016-2123.html
Get alerted when CVE-2016-2123 or the next vulnerability affects your stack