What’s Vulnerable › Vulnerabilities
CVE-2016-2138
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-28 · updated 2026-06-17
- Weakness: CWE-79
Description
In kippo-graph before version 1.5.1, there is a cross-site scripting vulnerability in xss_clean() in class/KippoInput.class.php.
Affected products
- kippo-graph: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: kippo-graph 1.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/ikoniaris/kippo-graph/commit/e6587ec598902763110b70c8bd0a72f7951b4997
- https://github.com/ikoniaris/kippo-graph/issues/35
- https://github.com/ikoniaris/kippo-graph/commit/e6587ec598902763110b70c8bd0a72f7951b4997
- https://github.com/ikoniaris/kippo-graph/issues/35
Get alerted when CVE-2016-2138 or the next vulnerability affects your stack