What’s Vulnerable › Vulnerabilities

CVE-2016-2140

Description

The libvirt driver in OpenStack Compute (Nova) before 2015.1.4 (kilo) and 12.0.x before 12.0.3 (liberty), when using raw storage and use_cow_images is set to false, allows remote authenticated users to read arbitrary files via a crafted qcow2 header in an ephemeral or root disk.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Nova 12.0.3, 2015.1.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2016-2140 or the next vulnerability affects your stack